Share
View previous topicGo downView next topic
avatar
brittech

Re: FORUM ALPHA TEST BUILDS

on Thu 8 Oct 2015 - 22:03
Message reputation : 100% (1 vote)
There are 10 core CPUs, such as the Intel Xeon E7-2850.

Edit:  Just checked Wikipedia, reference, https://en.wikipedia.org/wiki/List_of_Intel_Xeon_microprocessors

Looks like there are currently,  2, 4, 6, 8, 10, 12, 14, 15, 16, and 18 core Intel processors.
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: FORUM ALPHA TEST BUILDS

on Thu 8 Oct 2015 - 23:36
Hey brittech,

Thank you very much for this interesting information.
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 0:45
Message reputation : 100% (1 vote)
Hey,

Let's test v0.4.12.3 (alpha) !

Instructions:
- Use this build exclusively with the provided wccf file, otherwise you will experienced severe troubles !
- The full potential of the New Removing Engine is only valid for all components selected in the provided WCCF presets file !
- Consider it as unstable due to the alpha stage
- Create a dedicated folder to use this alpha build ... do not use your daily use folder

Changelog:
- UPDATE : "OPEN" window : GUI cosmetics improvements
- UPDATE : "WinReducerEX100.log" : Add time reference (start and finish) during phases "Mount" and "Apply"
- UPDATE : "Removing Engine v3.04" : Multithreading support from 1 core up to 12 cores
- UPDATE : "Removing Engine v3.04" : All profiles, including "Insane", may be used on all CPU (from 1 core up to 12 cores) without negative inpact on general system or software performance
- UPDATE : "FINISH" tab : Add available components number in the window top icon

- FIX : "Apply - ISO File Creator" : ISO folder path error, if path loaded from a WCCF
- FIX : ISO mounting with an old WCCF

Download Link:
[You must be registered and logged in to see this link.]

Components added in WCCF v0.4.12.3:
-

Compared to previous alpha build, there are new known bugs. So please read the "Known Bugs" section in the "Changelog.txt" file provided in the zip package.
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 0:45
Some important additional information :
- this is, without doubt, one of the most beautiful WinReducer build ever created ... a lot of work is always needed, especially with components cleanup, but in term of performance this is an excellent build !
- you could use all removing profiles, even "Insane" one, on all CPU ( from 1 core up to 12 cores) without troubles. This new "Removing Engine v3.04" is entirely multi-threaded, and it also automatically adapts the removing speed to your CPU speed and available cores !
- If you want the best speed deselect "EXPERT - Deep Cleanup" from the provided WCCF once loaded in WinReducer, and you may also avoid to do anything else during the removing

--> New components cleanup are coming in the next build !

EDIT : I need feedbacks on CPU with less than 4 cores, with "Insane" profile selected ... Jpm, I'm counting on you Wink
avatar
KrX

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 1:23
Message reputation : 100% (1 vote)
i tried it on my notebook:

14" Full HD                       
i7 5600U vPro 2.6 GHz        <--- 2 cores / 4 threads
16 Gb Ram                        
AMD Readon M260             
128Gb M.2 SSD
256 GB Kingston SSD

the error after mounting isnt showing up anymore

insane speed / 330 Components removed (just loaded the wccf file which came with the package)
it took 8 minutes (only winreducer running and a vm with xp installation) to get to the "create iso" part, 1:23 min to create the iso file

most of the time it used 96-98% of the cpu, sometimes it droped to 75-80 and went again up.
2.75Gb ram of 16gb were used ( 600mb vm)

so no problems so far, will test the iso later
avatar
caphp

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 7:36
Message reputation : 100% (1 vote)
WinReducer EX-100 - v0.4.12.3
with TEST_v0.4.12.3.wccf

Intel i7-3930K 6Cores/12Threads
Removingspeed: Insane

=>

Time to remove + create new iso = Total 08m05s

no loop, seems to work good under VMware Player

@winterstorm
All 6/12 Cores @ 90% working with 3,8 GHz.
Really good work my friend !!!
Thank you for this excelent work !!!

Time to remove apps = 04m04s
Time to remove all the rest + finalizing = 2m33s
Time to create iso = 01m28s

To my mind, there is no need to reduce the 2m33s.
The problem is only the removing apps time, but I think, this time can not be reduced, because, this dism command works really slow...
avatar
ruby2hora

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 9:37
Message reputation : 100% (1 vote)
Test v0.4.12.3 whit(331)components removed,

i5 2500K 3.30GHz 4 Cores/4 Threads
8GB Ram
Palit GeForce GTX 750 Ti
SSD 120GB(Work folder)

Removing speed: Insane.
Total time 8,15 minutes

                             It is super okay !
avatar
Jpm

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 10:36
Message reputation : 100% (1 vote)
Hi please find my tests

Test v0.4.12.3 with (331)components removed,

i5-3210M 2.50GHz 2 Cores/4 Threads
8GB Ram

HDD 1TB(5400 with 8GB SDD)

Removing speed: Insane.
Total time 27,42 minutes (including ISO creation)

I also try to remove the Antivirus (Windows Defender) no significant change.

In the Log it would be good to separate the ISO time creation
and perhaps to correct the nb cores as it reports 4 cores which is not correct for my Notebook.

Great job
Thanks Winter
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 11:08
Message reputation : 100% (1 vote)
Hello guys,

Thank you very much for all your reports !

KrX wrote:the error after mounting isnt showing up anymore
OK, excellent, thank you for the feedback about it.

KrX wrote:most of the time it used 96-98% of the cpu, sometimes it droped to 75-80 and went again up. 2.75Gb ram of 16gb were used ( 600mb vm)
The drop down around 75-80, is normal because there is component ("Languages - India") which needs to be upgraded. I will do upgrade it today almost as some other components Wink
@KrX : Just a question, are you still using a RAM Drive ?

caphp wrote:All 6/12 Cores @ 90% working with 3,8 GHz.
Really good work my friend !!!
Thank you for this excelent work !!!
Thanks Smile

caphp wrote:Time to remove apps = 04m04s. Time to remove all the rest + finalizing = 2m33s. To my mind, there is no need to reduce the 2m33s.
The problem is only the removing apps time, but I think, this time can not be reduced, because, this dism command works really slow...
I will upgrade it later to improve speed again, even for removing apps time Wink

Jpm wrote:Hi please find my tests. Test v0.4.12.3 with (331)components removed, HDD 1TB(5400 with 8GB SDD)
Removing speed: Insane.
Total time 27,42 minutes (including ISO creation)
Thank you for the report. Have you looked at the task manager to see the level of use of all your threads ? Are they all used around 90-95% ?

Jpm wrote:I also try to remove the Antivirus (Windows Defender) no significant change.
It seems that the limiting factor is the HDD (which is by definition slower in access than an SSD). If you have time try this :
1 - deselect in the provided WCCF v0.4.12.3 the component "EXPERT - Deep Cleanup". This should save you some time, how many I don't know, but this is the point : if possible I would like to know the time difference between selecting it and not selecting it. If you could do this, this should be a precious information for me. Thanks by advance Jpm.
2 - before launch EX-100, test if your HDD is fragmented. Maybe defragmenting it is needed.

Jpm wrote:In the Log it would be good to separate the ISO time creation
It will be added in the next build Smile
EDIT : Done !

Jpm wrote:and perhaps to correct the nb cores as it reports 4 cores which is not correct for my Notebook.
You are right about this, I need to correct it because the most important for the cleanup is not the number of CPU cores but the number of CPU threads. So, I will change the name from "Cores" to "CPU Threads". Wink
EDIT : Done !

--> So, with the new "Removing Engine - 3.04" :
- the faster your CPU is, the more removing speed you will get
- an SSD is recommended to achieve the best removing speed
avatar
Jpm

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 12:05
Hi Winter,
The Cpu is around 100% not sure Under my system I need so many cmd/SetACL proceses
I will test and report the "Deep Cleanup"

Sniff I cannot add a SSD to my notebook

Cheers
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 12:14
If you want to have a better idea of all charges on all individual CPU Threads, just use the "Resources Manager" (llink avaibale at the bottom of the "Performance" tab in the "Task Manager" ...

Then choose "Processor" tab and you will see all CPU Threads, this is a much better representation for all CPU Threads than in the "Task Manager".

Wink
avatar
KrX

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 13:17
winterstorm2050 wrote:@KrX : Just a question, are you still using a RAM Drive ?

at the moment no. i reinstalled my windows 7 yesterday and after that the first things i did was installing xp on my vm and running winreducer at the fresh installed os
avatar
Jpm

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 15:13
Hi,
 I have a silly old question
in my .wccf I have
   
In fact I was in the impression that this .cmd will taken in account but in fact no
to have it working I need to open the system->winreducerPost-installation->OOBE
at this time I see the content and it will be include in the .iso
Can it be included without doing the trick to open the OOBE Tab
Cheers
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 19:18
Hey,

Let's test v0.4.13.3 (alpha) !

Instructions:
- Use this build exclusively with the provided wccf file, otherwise you will experienced severe troubles !
- The full potential of the New Removing Engine is only valid for all components selected in the provided WCCF presets file !
- Consider it as unstable due to the alpha stage
- Create a dedicated folder to use this alpha build ... do not use your daily use folder

Changelog:
- UPDATE : "Removing Engine v3.05" : Multithreading support for up to 20 CPU Threads
- UPDATE : "Removing" window : GUI cosmetics improvements while using window size reduction icon
- UPDATE : "WinReducerEX100.log" : Add time reference (start and finish) during phases "ISO Creation"
- UPDATE : "WinReducerEX100.log" : Changed "CPU Cores" reference to "CPU Thread(s)" reference
- UPDATE : "Accessories - Windows Mail" : Cleanup improvements
- UPDATE : "Keyboards - India" : Cleanup improvements

- FIX : "Optimizations" : Incorrect values loaded from a previous WCCF

Download Link:
[You must be registered and logged in to see this link.]

Components added in WCCF v0.4.13.3:
-

Compared to previous alpha build, there are new known bugs. So please read the "Known Bugs" section in the "Changelog.txt" file provided in the zip package.
avatar
caphp

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 19:58
Its getting faster and faster ... Very Happy


Code:
***** 09.10.2015 19:22:37 - SESSION OPENED *****
***** 09.10.2015 19:23:52 - Windows Edition [Mounting] - Started
***** 09.10.2015 19:24:59 - Windows Edition [Mounting] - Finished
***** 09.10.2015 19:25:34 - Windows Edition [ISO Creation] - Started
***** 09.10.2015 19:25:34 - Windows Edition [ISO Creation] - Finished
***** 09.10.2015 19:25:44 - Windows Edition [Configuration] - Started
INFO : CPU Thread(s) : 12
INFO : Removing Profile : Insane
***** 09.10.2015 19:31:52 - Windows Edition [Configuration] - Finished
***** 09.10.2015 19:31:52 - Windows Edition [ISO Creation] - Started       
***** 09.10.2015 19:33:15 - Windows Edition [ISO Creation] - Finished
***** 09.10.2015 19:33:17 - SESSION CLOSED *****

Removing Apps in 3m28s
Removing (see [Configuration]) in 6m08s cheers
avatar
KrX

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 20:54
hey caphp can you install the iso from this version ?

just loading the wccf file included in this version gives this error during installation



edit:

***** 09.10.2015 20:29:59 - SESSION OPENED *****
***** 09.10.2015 20:30:51 - Windows Edition [Mounting] - Started
***** 09.10.2015 20:32:17 - Windows Edition [Mounting] - Finished
***** 09.10.2015 20:32:36 - Windows Edition [ISO Creation] - Started
***** 09.10.2015 20:32:36 - Windows Edition [ISO Creation] - Finished
***** 09.10.2015 20:32:40 - Windows Edition [Configuration] - Started
INFO : CPU Thread(s) : 4
INFO : Removing Profile : Insane
***** 09.10.2015 20:41:35 - Windows Edition [Configuration] - Finished
***** 09.10.2015 20:41:35 - Windows Edition [ISO Creation] - Started
***** 09.10.2015 20:43:25 - Windows Edition [ISO Creation] - Finished
***** 09.10.2015 20:43:28 - SESSION CLOSED *****

edit 2:  cant say if its a problem of this version because i didnt test the last maybe 3 versions on my vm
avatar
caphp

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 21:43
Hi KrX,

I did not get an error message.
Installation worked fine for me.
I used VMware Workstation 12 Player build 2985596
I used (as always) de_windows_10_multiple_editions_x64_dvd_6846954.iso
avatar
KrX

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 21:56
caphp wrote:Hi KrX,

I did not get an error message.
Installation worked fine for me.
I used VMware Workstation 12 Player build 2985596


i get the error wth virtual box. i tried it now with vm ware workstation 12 and it happens there too.

i will do some tests to find whats causing it
avatar
caphp

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 22:19
I do not take modifications (because of alpha testing).
I simple used the WinReducer100_v0.4.13.3.wccf
avatar
KrX

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 22:21
caphp wrote:I do not take modifications (because of alpha testing).
I simple used the WinReducer100_v0.4.13.3.wccf

thats exactly what i did Wink

i use win10 x64 build 240 with updates integrated till august.
avatar
caphp

Re: FORUM ALPHA TEST BUILDS

on Fri 9 Oct 2015 - 23:18
Then the difference is, that I dont integrate updates so far.
avatar
Voz

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 0:19
Hi KrX

I had that problem too with Windows 8.1. because i removed the feature, Internet Information Services. framework 3.5 needs this i think?

v0.4.13.3
***** 9-10-2015 22:36:31 - SESSION OPENED *****
***** 9-10-2015 22:38:30 - Windows Edition [Mounting] - Started
***** 9-10-2015 22:41:58 - Windows Edition [Mounting] - Finished
***** 9-10-2015 22:44:02 - Windows Edition [ISO Creation] - Started
***** 9-10-2015 22:44:02 - Windows Edition [ISO Creation] - Finished
***** 9-10-2015 22:44:24 - Windows Edition [Configuration] - Started
INFO : CPU Thread(s) : 8
INFO : Removing Profile : Insane
***** 9-10-2015 23:10:52 - Windows Edition [Configuration] - Finished
***** 9-10-2015 23:10:52 - Windows Edition [ISO Creation] - Started
***** 9-10-2015 23:19:07 - Windows Edition [ISO Creation] - Finished
***** 9-10-2015 23:19:10 - SESSION CLOSED *****

Works in VirtualBox. only Pre-enabled framework 3.5 and updates till september
avatar
KrX

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 2:37
Voz wrote:Hi KrX

I had that problem too with Windows 8.1. because i removed the feature, Internet Information Services. framework 3.5 needs this i think?

v0.4.13.3
***** 9-10-2015 22:36:31 - SESSION OPENED *****
***** 9-10-2015 22:38:30 - Windows Edition [Mounting] - Started
***** 9-10-2015 22:41:58 - Windows Edition [Mounting] - Finished
***** 9-10-2015 22:44:02 - Windows Edition [ISO Creation] - Started
***** 9-10-2015 22:44:02 - Windows Edition [ISO Creation] - Finished
***** 9-10-2015 22:44:24 - Windows Edition [Configuration] - Started
INFO : CPU Thread(s) : 8
INFO : Removing Profile : Insane
***** 9-10-2015 23:10:52 - Windows Edition [Configuration] - Finished
***** 9-10-2015 23:10:52 - Windows Edition [ISO Creation] - Started
***** 9-10-2015 23:19:07 - Windows Edition [ISO Creation] - Finished
***** 9-10-2015 23:19:10 - SESSION CLOSED *****

Works in VirtualBox. only Pre-enabled framework 3.5 and updates till september

yes i remember Internet Information Services was causing problems, but the provided wccf file doent remove any features or services. only components from the remover tab
scottallthefriends

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 7:32
It's not immediately obvious there is a second tab with more cursor options

scottallthefriends

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 7:35
Between version 4.3 and the current alpha 14.13.3 you seem to have dropped being able to remove Bing Food and Drink, Health and Fitness, and Maps. Why? I want to get rid of them! Razz

avatar
ruby2hora

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 8:46
My test:
v0.4.13.3
***** 10.10.2015 09:27:42 - SESSION OPENED *****
***** 10.10.2015 09:27:56 - Windows Edition [Mounting] - Started
***** 10.10.2015 09:28:43 - Windows Edition [Mounting] - Finished
***** 10.10.2015 09:29:00 - Windows Edition [Configuration] - Started
INFO : CPU Thread(s) : 4
INFO : Removing Profile : Insane
***** 10.10.2015 09:37:22 - Windows Edition [Configuration] - Finished
***** 10.10.2015 09:37:22 - Windows Edition [ISO Creation] - Started
ERROR : 10.10.2015 09:38:45 ==> ISO File Creator (Save in an ISO File)
***** 10.10.2015 09:38:48 - SESSION CLOSED *****

                                                                 Who had the idea with the log file is a smart guy...   Smile


Last edited by ruby2hora on Sat 10 Oct 2015 - 8:52; edited 1 time in total
avatar
caphp

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 8:49
Message reputation : 100% (2 votes)
Hi Scottallthefriends,

because we are in a alpha test and till now, there are several things tested to create the next beta build. Its not mentioned to remove as many components, but the way how they are removed is important.
So you have to wait for next beta, or use the last beta, or even better, you can help to test the alpha versions.
avatar
Jpm

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 13:02
Hi,
Is it possible to Have the WORK\EXTRACT and WORK\MOUNT folders in the different directory than \HOME and WinReducerEX100.exe?
Thanks for the help
avatar
caphp

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 13:43
Hi Jpm,

you can take a look at the mklink command.
Maybe this link might help you:
[You must be registered and logged in to see this link.]
avatar
KrX

Re: FORUM ALPHA TEST BUILDS

on Sat 10 Oct 2015 - 13:51
Message reputation : 100% (1 vote)
Jpm wrote:Hi,
Is it possible to Have the WORK\EXTRACT and WORK\MOUNT folders in the different directory than \HOME and WinReducerEX100.exe?
Thanks for the help

to change the extract folder you will need to extract your iso manually and at the winreducer folder select FOLDER

to change the mount folder goto Options -> configuration and set the button for MOUNT to OFF, after that click on the name MOUNT and select some other folder
View previous topicBack to topView next topic
Permissions in this forum:
You cannot reply to topics in this forum