Share
View previous topicGo downView next topic
avatar
Zx10-r

0.9.4 behavior

on Sat 13 Aug 2016 - 18:43
Hi all, i m slimming the th2 build (the host machine is a vbox 8.1): the first time that WR extract from dvd everything goes well, meaning that shows all components and I can select wathever I want and apply as usual (saving the preset).
And here comes my problem: all the following times that I load the same original image from the iso as before, WR doesn't shows anymore all the components: more precisely WR shows all the components except the ones that I removed in the previous session as if they were no longer present.
Any suggestion will be appreciated.
Thank you.
avatar
Geekster

Re: 0.9.4 behavior

on Sat 13 Aug 2016 - 20:44
You are absolutely correct and that's what should happen.  Once you remove a component and then run WinReducer using the same presets those components will no longer be shown.  If you want to make changes then you need to start with a fresh ISO and don't use any previous presets.

The Geekster
avatar
Zx10-r

Re: 0.9.4 behavior

on Sat 13 Aug 2016 - 21:19
Hi and thanks for your attention.
Do you mean that the presence of an preset in the extraction folder change the offset of WR ?
I ask cause the image (or the iso) is the same with no change from the session 1 to the session 2 and, consequently, the offset should be the same.
I ll try to figure this:

Step 1: load the "X" image that shows "N" components and I remove "Y" components.

Step 2: load the same image that shows "N" components - the "Y" components that I removed before.

How can I change my choice about removing different components ?
Why that happens if the image has not been changed ?
avatar
KrX

Re: 0.9.4 behavior

on Sun 14 Aug 2016 - 12:33
hi,

did you insert an wccf file in the root directory of your image (iso) ? if yes thats why the components arent shown anymore.

Winreducer normally extracts the iso and checks if an wccf file is present, if yes it hides all components that were removed before. So if you want to see again all components move/delete the wccf file from the root directory and mount your image again.
avatar
Geekster

Re: 0.9.4 behavior

on Wed 17 Aug 2016 - 1:35
Message reputation : 100% (2 votes)
I will answer this part of the question because the rest of your questions only raises more questions   lol   As most of us here including myself have had learn by experience and you will too in time so be patient and take your time.  And KrX is very knowledgeable and he has been my Yoda of WinReducer   I love you  Actually is quite good at pointing you to a link and telling you to go and read some more!   haha

How can I change my choice about removing different components ?

If you want this to be fool proof this is the rule I have always followed and I know that WinterStorm wrote this as well somewhere else on this website. But the best answer is ALWAYS start with a good ISO and you can take your pick from the ones people here have used.  If ever in doubt about whether an ISO is good or not, I take the safest route and download it again from the original source (usually Microsoft).  Be sure to trash all the others.

And then start out with one of these two choices:

Choice 1) Start all over with none of the presets changed and then go from there.  I learned a long time ago too, don't change so many presets that you lose track of which ones are doing what.  Always be certain that you choose your presets carefully.  This is vitally important to be an effective tester.  If you use an image that was created by WinReducer and try to apply some more presets then you are only inviting trouble and you have only yourself to blame.  More importantly though is that method is NOT a valid test of WinReducer and defeats the purpose of helping us test.

Choice 2) Again use only a fresh ISO as I suggest in Choice 1 but this time use a previous set of presets that you already used and they will be listed under YourWREX100 directory/Home/Presets/LastUsed.  You might wanna clean this directory out especially if you can't remember which ones were good and which are bad.  And when you execute WREX100 and after you get your ISO of choice mounted then click on the LOAD button and select your WCCF file that contains your presets that you want to work with.  Also take note of the Clear Settings button and that's a nice little panic button if you forget what your doing  geek  Now you will notice that only the presets you used before are now again set, however, now we finally get to your original question above and now if you want to change your mind and put that component back in, now is the time to do so.  Likewise, if you wish to select more components this is where you can do that as well.

Hopefully I at least answered that one question in particular and it may answer the others as well.

The Geekster


Last edited by Geekster on Wed 17 Aug 2016 - 23:57; edited 2 times in total
avatar
KrX

Re: 0.9.4 behavior

on Wed 17 Aug 2016 - 12:17
Message reputation : 100% (1 vote)
thats a good post, i hope it will help a lot of People !


Geekster wrote:And KrX is very knowledgeable and he has been my Yoda of WinReducer   I love you

haha thanks lol!  Very Happy, there are still things that i dont know and need to learn for myself Wink
View previous topicBack to topView next topic
Permissions in this forum:
You cannot reply to topics in this forum