Share
Go down
avatar
Hanyo

[EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Mon 28 May 2018 - 12:09
Although I don't use the option winsxs compression (install.wim) the installation of the cumulative update KB4103720 fails with errorcode 0x80073701 (Assembly Missing). Is this because of a removed component?


Last edited by Hanyo on Tue 5 Jun 2018 - 11:42; edited 1 time in total
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Mon 28 May 2018 - 20:30
Hello Hanyo Smile

Yes, this seems to be a bug, could you please send me your wccf ... I will have a look at this Smile

Don't forget to remove your serial number in your wccf.

Thanks.
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Mon 28 May 2018 - 21:08
This is my wccf: Klick
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sat 2 Jun 2018 - 12:16
The same with EX-100 - v1.9.19.0

avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Mon 4 Jun 2018 - 7:20
In an unreduced ISO KB4103720 is installable. So it really seems to be a bug and this thread should be moved ti the Bug section.
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Wed 13 Jun 2018 - 8:03
I made my tests above with an ISO with some integrated updates. When I use my wccf with an ISO without integrated updates, I get 3 errors when updating ("Fehler" = "error"): I also tried to isolate one option in Winreducer that causes this problem with no success: It seems that just using winreducer causes it. Unfortunately there is no update-catalog for LTSB2016.

avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Thu 14 Jun 2018 - 15:49
Hello Hanyo,

Could you please try this :
- use an official ISO (without modification or updates integrated)
- slipstream the latest updates (downloaded using "Updates Downloader" in EX-100)
- test your iso
- then use this updated iso to customize it with your wccf
- test your iso

Please let me know. Thanks.
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sat 16 Jun 2018 - 16:50
Because there is no update catalog for Enterprise LTSB I made this test with an official RS4-ISO. I integrated KB4284835 and KB4287903 with Winreducer. Surprisingly the installed Windows detects the KB4284835 as not installed:



That should't be I think. But after installing all updates everything looks good:




After reducing the updated ISO with my wccf above, Update runs through with this result:



No cumulativ update is installed, but that's logical because it was already integrated. (But why not in the unreduced installation?). I think, I should repeat the test with LTSB, right?
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sat 16 Jun 2018 - 20:28
I don't know how to integrate LTSB-updates with winreducer without using that Winreducer Update tool (which has no LTSB-support). I just copied LTSB-updates into a folder and enter the path into the update-box, but that doesn't work, the updates are not integrated.

I tried to do it "manually" with DISM but get an error durig the integration of the second update. I had that before, so I integrated just some working updates. No need to repeat that becauses I explaind already above what happens then.
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sat 16 Jun 2018 - 20:42
Hello Hanyo Smile

LTSB 2016 is supported in EX-100, because this is a Windows 10 v1607 (with a LTSB support though) ... you just need to select all updates for "RS1 (v1607)", in the "Updates Downloader" tool !

After this, you must select the correct folder :
- in the "System - Integrate Updates" option : click on "..." button
- then immediately select "OK" button, the correct path folder should be displayed in the "System - Integrate Updates" text field

And the same procedure could be deployed for RS4 updates in the "Updates Downloader" and Windows 10 RS4 iso.

Wink
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sat 16 Jun 2018 - 22:05
I did it like this when I integrated the updates for RS4 and I know that LTSB2016 is based on RS1 but I think the uptates from the Microsoft Update Catalog are not the same as for RS1, because they are described as specially for LTSB. Are you sure they are the same anyway??
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sat 16 Jun 2018 - 22:09
Yes ... they are compatible with Windows 10 and Windows 10 LTSB Smile
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Mon 18 Jun 2018 - 6:35
Results of my test with LTSB2016 using the Winreducer update tool:

In the unreduced installation again one update that should already be integrated is found: KB4132216. But all Updates are installed successfully.

In the winreduced installation I have the same errors as described above! 3 updates can't be installed ("Fehler" = "error"):

avatar
funkmunk

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Wed 27 Jun 2018 - 12:30
this is not a winreducer problem; the latest cumulative update cannot be integrated into any iso. i tried both LTSB2016 ENT and home/pro version. there seems to be something wrong with the KB4284833 (OS Build 14393.2339) 


i even tried to slipstream this update with DISM, IT JUST DOESN'T INTEGRATE  Neutral


maybe it is because MS changed some files so it cannot be integrated and only updated through wsus because of the end of support for other 1607 versions?
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Wed 27 Jun 2018 - 13:23
But that doesn't explain why Windows Update doesn't install all updates it finds.
avatar
funkmunk

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Wed 27 Jun 2018 - 13:47
i dont know either, but i suspect its because of previous issues; you cant update from 14393.0 directly to 14393.2339 either. first you have to update to 2312 and apply 2 other small patches. i tested this on VM twice and it gets stuck around 50% installing the update.
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Thu 28 Jun 2018 - 17:27
I think I made a mistake when trying to integrate the drivers and reducing the ISO in one pass. I think the updates had not been integrated at all. I didn't realised that because I never stay watching the messages when Winreducer is working. That lead to the result that Windows Update found an update which I thought it was integrated already.

Therefore I repeated the test, this time I made a ISO just with 3 integrated RS1-updates from the winreducer update tool (and updates file cleanup), no reducing. Result: Windows update found 3 more updates (especially KB4284833), so no already integrated update. But as funkmunk stated, KB4284833 can't be installed:


Actually the problem has nothing to do with any reducing of the ISO and that's the reason why I couldn't identify a component that causes it.
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Fri 29 Jun 2018 - 0:07
Hello guys Smile

I will release a new EX-100 catalog updates in few minutes ... and I didn't remove KB4284880 (for system update to 2312) and I added the newest KB4284833 (for system update v2339).

I will do further investigations, but if you have time, please try to integrate all these updates, according to funkmunk comment.

Let me know how this works. Thanks.
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sat 30 Jun 2018 - 18:32
I integrated just KB4132216 into the ISO and with that ISO Windows Update installs all updates it finds without error, including KB4284833. But unfortunately when I reduce this ISO the installation of KB4284833 fails again.

This means that it is more than a Windows problem but also a problem of reducing it. It might has to do with missing components. In [You must be registered and logged in to see this link.] winter said:

The fact that the update is not installed should be linked to the fact that some components are removed ... but I'm also working on this point to bypass these troubles 
avatar
funkmunk

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sun 1 Jul 2018 - 2:08
Hanyo wrote:I integrated just KB4132216 into the ISO and with that ISO Windows Update installs all updates it finds without error, including KB4284833. But unfortunately when I reduce this ISO the installation of KB4284833 fails again.

This means that it is more than a Windows problem but also a problem of reducing it. It might has to do with missing components. In [You must be registered and logged in to see this link.] winter said:

The fact that the update is not installed should be linked to the fact that some components are removed ... but I'm also working on this point to bypass these troubles 

i dont understand what you are trying to do here.  Why would you update a reduced iso? and how do you that actually? normal order should be:

clean iso >>> update KB4132216  and KB4284833 >>> reduce >>> save iso  (i use extreme custom presets, so absolutely no point in updating those. for me its about core system and major security updates)
avatar
Hanyo

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sun 1 Jul 2018 - 6:46
I want to use Enterprise LTSB because I want to use the update functionallity. I don't want to use RS4 for that because I don't want to get feature updates. But because the update doesn't work, I now use a reduced RS4 again with removed Windows Update. Why integrate updates into a RS1 when you have a RS4?

With Win7 I always used Windows Update and it worked.
avatar
funkmunk

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Sun 1 Jul 2018 - 9:23
alright, i understand. i dont know how much you have removed, but installing major cumulative updates will always have issues with a reduced iso. 


i have managed to intergrate KB4284833 after integrating KB4132216  first.  thx winter 
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Thu 12 Jul 2018 - 18:25
Hello guys Smile

I will release in few hours the EX-100 July Catalog in few hours, I removed the KB4284880 (Jule CU) from it, because I successfully integrated the new July Cumulative Update KB4338814 in the LTSB 2016 ISO.

Please let me know how this will work for you and if there are troubles with WinReduced ISO.

Thanks Smile
avatar
AeonX

Re: [EX100 - v1.9.18.0] [Enterprise LTSB 2016] Upate fails

on Tue 17 Jul 2018 - 1:00
Hanyo wrote:With Win7 I always used Windows Update and it worked.

To use Windows Update the best option is Win8.1 because it download little data and uses little resources when searching for and installing updates (not like Win10) and does not increase the disk space over time with multiple updates (not like Win7) because it has the dism /cleanup-image /startcomponentcleanup functionality (a scheduled task that is default) or you can manually run dism /online /cleanup-image /startcomponentcleanup /resetbase to clean more deeply (in Win8.1 and Win10 but not in Win7).

In Win10 RS1 (LTSB) Windows Update uses a lot of PC resources (high CPU and disk usage) only in searching for updates and logic than installing it much more. In RS3 does not have this problem (I did not test in RS2 and RS4) but when installing download more data and consumes more resources than Win8.1 in addition to having the problem of feature updates.

Hopefully in the next LTSB version they fix these "bugs" with the Windows Update search even when new builds come out after it.
Back to top
Permissions in this forum:
You cannot reply to topics in this forum