Go down
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty [EX-100 2.1.9.0] [RS5] Update integration fails

on Wed 4 Sep 2019 - 8:33
Winterstorm stated: "this version solves many troubles with installation but there are still problems using few "Services" components with "Windows Update". In fact, I can't produce an installable ISO with the following wccf, regardless of whether I'm using "Expert: update cleanup" or not or "Protect Windows update" or not. When I don't integrate updates everything works fine.

Here my wccf: klick
Here the error message using "protect windows update":

 [You must be registered and logged in to see this link.]

"unexpected error during windows installation"

Does anybody know which services are causing this?
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 11:35
I kept all servicec but got the same result. Conclusion: It has nothing to do with services.

I integrated just the updates with winreducer, nothing else. Then I reduced the updatet iso with this wccf: klick. It works. Conclusion: The error occures because winreducer integrtes the updates after reducing at the end, when Windows Update ist kept. I suppose I got the error because I used WinSxS cleanup.

So first update integration, then reducing seems to be better than the other wasy round. Why do winreducer put it at the end when windows update is kept? When Windows update isn't kept, The integration is in the first place.

Strange is also that I don't get an working iso when I make the update integration and the reducing in one pass, even when I uncheck Windows update so that the integration is in the first place. Any idea why?
winterstorm2050
winterstorm2050
Admin
https://www.winreducer.net/

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 11:38
Hello Hanyo Smile

Please try without using "Optimizations - EXPERT - Windows Updates Files Cleanup" ?

Let me know, thanks Smile
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 12:16
Hi winter,

what do you mean exactly? In my first try (see first post) I deselected Update files cleanup:  
  
Element Category="Optimizations" Name="EXPERT - Windows Updates Files Cleanup" Selected="false" Value="" /
winterstorm2050
winterstorm2050
Admin
https://www.winreducer.net/

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 12:39
I just saw that in your second post, you provide a wccf download link in which you selected the "Optimizations - EXPERT - Windows Updates Files Cleanup" Wink
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 14:27
Yes, and the update cleanup seems to be no problem when the update integration is before the reduction. But maybe update cleanup is the cause that the creation doesn't work in one go. I will test it.
neo
neo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 16:58
hi Hanyo,

From your WCCF,

Following items of high risk - possibly breaking the OS functionality / setup:
============================
Features  -  Net Framework 4.6 Network Advanced Services
Features  -  Windows PowerShell
Remove - Modern UI Apps  -  Framework (Advertising SDK)
Remove - Modern UI Apps  -  Framework (Chat)
Remove - Modern UI Apps  -  Framework (Contact)
Remove - Modern UI Apps  -  Framework (Email)
Remove - Modern UI Apps  -  Framework (Microsoft Store Services)
Remove - Modern UI Apps  -  Framework (People)
Remove - Modern UI Apps  -  Framework (Phone Call History)
Remove - Modern UI Apps  -  Framework (Task)
Remove - Modern UI Apps  -  Framework (User Data Account)
Remove - Modern UI Apps  -  Framework (Windows Mixed Reality SDK)
Remove - Modern UI Apps  -  Framework (Xbox LIVE Games)

Also consider to keep these:
Remove - Accessories  -  Administrative Tools (Firewall)
Remove - Accessories  -  Administrative Tools (Firewall) Shortcut
Remove - Accessories  -  ELS (Extended Linguistic Services)
Remove - Accessories  -  Imapi
Remove - Accessories  -  Run Legacy CPL Elevated
Remove - Drivers  -  Network - Ethernet - Virtual

and For the following feature, keep the default:
WinReducer Options  -  Removing Speed

Regards,
Neo
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 17:09
Hi neo,

thank you for these hints. But do you have an explanation why it works when I integrate the updates before reducing the iso, even if I remove all that components you mention?
neo
neo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 17:13
Hanyo,
If it worked on certain scenario and failed on another, it's inconsistent, in such a case, I'd still stick with what's safe and stable.
Per your last reply, I'd check if the reducing-speed has any impact on the results.
But I would never remove .Net functionality, it's the core to memory management, and some security features too.

Neo
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sat 7 Sep 2019 - 17:48
I've been removing parts of the .Net framework for years and never had any problems. In fact, I only have problems when I integrate updates. I'm writing this from a system created with the same wccf as in the second post, except I didn't integrate updates. It's been running fine for months and the previous installations did the same.
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sun 8 Sep 2019 - 10:18
Even if update cleanup is deactivated, it is not possible to install the ISO. I get the following error message:

[You must be registered and logged in to see this link.]

Setup says, that a reboot and an update is needed. When I go on, setup freezes with "a moment please". Maybe this will change, but I'm waiting now since half an hour, so this is defenately not normal.

Conclusion: 

The update integration does not work, no matter whether

* windows update is selected or not

* update cleanup is selected or not

The only way to integrate updates is to do it in two steps.
KrX
KrX

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sun 8 Sep 2019 - 12:50
Hanyo wrote:Even if update cleanup is deactivated, it is not possible to install the ISO. I get the following error message:

[You must be registered and logged in to see this link.]

Setup says, that a reboot and an update is needed. When I go on, setup freezes with "a moment please". Maybe this will change, but I'm waiting now since half an hour, so this is defenately not normal.

Conclusion: 

The update integration does not work, no matter whether

* windows update is selected or not

* update cleanup is selected or not

The only way to integrate updates is to do it in two steps.


hey,

i get this error message only with my RS6 (updated with winreducer, german) iso and ONLY if i deactivate services. removing them is ok.

so far i removed everything winreducer offers and i can install the iso. as soon as i found what components in services cause it i will post it.

i didnt look at your wccf but did you deactivate any services?
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Sun 8 Sep 2019 - 22:03
Yes, I deactivated some services.

Edit: But why is it possible to install the ISO with the same deactivated services when creating it in two passes? And the error in the first post above has nothing to do with services because it also appears when keeping all services.
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Tue 10 Sep 2019 - 11:40
With EX100 v2.2.0.0 and the following wccf I produced again an updated ISO. But this time I tried to install this unreduced ISO in a VM. I havn't done this in my two-pass-test above.

I just integrated the updates from the Winreducer Update catalouge. Here the wccf: klick

Installation isn't possible! I get this error message:

[You must be registered and logged in to see this link.]

Klick on "Wiederholen" (= retry) leads to the same message again, klick on "Überspringen" (= skip) leads to a loop and after a while again to this screen.

Conclusion: Already the integration of the updates does't work as it should. So all problems mentioned here could be a consequence of that.

Could someone confirm this phenomenon?
winterstorm2050
winterstorm2050
Admin
https://www.winreducer.net/

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Tue 10 Sep 2019 - 12:15
Hello Hanyo Smile

Is it possible that you may try to confirm using VMware Player with the same ISO ?

Thanks.
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Tue 10 Sep 2019 - 14:38
Hi Winterstorm,

I will test it soon. I couldn't do it immediately because I have to reboot my Computer to install VMware.

I did the second pass (reduction) with my updated ISO produced with v2.2.0.0. Result: Not installable in VirtualBox (!). I get a loop during installation and afterwards this:

[You must be registered and logged in to see this link.]

Although it could be due to VirtualBox, it is different from v1.9.9.0, because it worked there. The ISO from v2.2.0.0 is a little bit bigger (1.85 GB instead of 1.83GB).
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Tue 10 Sep 2019 - 18:00
Both ISOs produced wit v2.2.0.0 (with updates and reduced) are installable in VMware. Now I will test an 1-pass-ISO in VMware. Unfortunately I must produce a new one because I deletet one because I thought it is not functional.
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Tue 10 Sep 2019 - 22:22
A 1-pass-ISO (updates and reducing) with v2.2.0.0 does NOT work in VMware either. I get the following error (I remember, I had that before):

[You must be registered and logged in to see this link.]

"The installation was aborted."

Conclusion: I had to do with two different errors: One with VirtualBox which seems to be not compatible with Winreducer AND a problem with integrating updates.
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Wed 11 Sep 2019 - 16:13
A 1-pass-ISO (update and reducing) from a RS6-ISO is also not installable in VMware player. I get the same error message like above with RS5.
winterstorm2050
winterstorm2050
Admin
https://www.winreducer.net/

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Thu 12 Sep 2019 - 15:27
Hello Hanyo,

Could you please describe me the entire procedure to be able to reproduce this.

If possible, could please provide me your wccf Smile

Thanks Smile
Hanyo
Hanyo

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Thu 12 Sep 2019 - 16:28
Thanks, winterstorm, for helping me.

Here ist the wccf for my 1-pass-tests: klick.

I used ISOs from this source: https://tb.rg-adguard.net/public.php. I tested with Win10_1809_German_x64.iso and Win10_1903_V1_German_x64.iso (with the same result). In both cases I choosed Index 5 "Professional". I integrated all updates from the winreducer update catalouge (and nothing else, folder was cleaned before).
winterstorm2050
winterstorm2050
Admin
https://www.winreducer.net/

[EX-100 2.1.9.0] [RS5] Update integration fails Empty Re: [EX-100 2.1.9.0] [RS5] Update integration fails

on Thu 12 Sep 2019 - 20:35
Hanyo,

I confirm the bug, I was able to reproduce it with my french rs6 iso Wink

This what I've done to bypass this trouble until it will be fixed :
- I updated my rs6 iso (without modification)
- I mounted again this rs6 iso and use your wccf ... without the unattended part  .... and without "EXPERT - Windows Updates Files Cleanup", which is by the way buggy in this situation (I've already found why, so I will deploy a fix soon)
- I use this customized rs6 iso in vmware player and it worked

So, there is a bug ... I will propose a fix as soon as possible ... and like all other installation bugs, these kind of bugs have the highest priority in my todo list !

Thank you very much for your report !

I wish you to have a great day !
Back to top
Permissions in this forum:
You cannot reply to topics in this forum