Share
View previous topicGo downView next topic
avatar
TryToRemember

[ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Tue 21 Oct 2014 - 17:07
Recently discovered winreducer... amazing...

All the images that I have build are great! computers run superfast...
No matter what I tried, I cant get .net Framework to work... 
Tried to protect sysprep, tried without expert optimization, tried updates.. tried integration... Nada
This is the only tutorial that seems useful but im not sure how to execute these commands...in cmd. 

Hen RyHallo,

  • you take original install.wim 
  • DISM /image:sources /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:\sxs 
  • Dism /Image:sources /Enable-Feature /FeatureName:NetFx3 /All 
  • Dism /image:sources /Get-FeatureInfo /FeatureName:NetFx3 
  • Dism /Unmount-Image /MountDir:sources /Commit 
  • Winreducer start






Features and the Net Framework 3.5 is no longer grayed out




Tried this DISM /image:sources /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /C:\Users\AAA\Desktop\WinReducer81\WORK\EXTRACT\ExtractedByWinReducer\sources:\sxs 
But keep getting errors 
Error: 2
Unable to access the image....
avatar
brittech

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Mon 27 Oct 2014 - 10:41
Hi

This is how it worked for me.

I mount an untouched/original WIM and enable NetFX3 first (before I add any updates!!)

Code:
dism   /mount-image   /imagefile:D:\Win81x64\sources\install.wim  /index:1   /mountdir:D:\wimoffline
dism   /image:D:\wimoffline   /enable-feature   /featurename:NetFx3   /All
dism   /commit-image   /image:D:\wimoffline
ABOVE CODE IS INCORRECT, please see SL2 post below for correction.

Then I add all my updates, including .NET 3.5 updates...  So far this has worked.


Last edited by brittech on Tue 27 Jan 2015 - 22:08; edited 1 time in total
avatar
home7ech

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Sat 22 Nov 2014 - 21:23
Hi TryToRemember,

i agree with brittech ..enable NetFX3 first (before I add any updates!!) is not worked in cases integrate (implement) windows 8.1 update-1. i'll recommended to add-packages windows 8.1 update-1 first > enable NetFX3 feauture, then all any updates.


i have simple batch File : click here
filename: Implement Windows_8.1_Update-1_x86 using DiSM Manually.cmd
Show Screenshot:

Corrections, after re-integrate "Windows Updates Downloader (2015-03-25) and 
enabling NetFX3 feauture" manually with DiSM v6.4.9879.0, then get results:
1. add-packages windows 8.1 update-1 and other updates first then enabling NetFX3 feauture(s)
get error: 0x800f0081f at 62.9% result.
Screenshot:

2. so i reverse enabling NetFX3 feauture(s) first then add-packages windows 8.1 update-1 
and other updates with little modification in CMD Code

Code:
SET WiNSRC=X:
SET WORKDiR=D:\Projects\[DEV]
SET WR81=%WORKDiR%\WiN8.1\ExtractedByWinReducer
SET DiSMW10=%WORKDiR%\TOOLS\[DiSM]\v6.4.9879.0\dism.exe

REM Mount and Modify Windows 8.1 Image, please wait ...
SET MOUNT=%WORKDiR%\MOUNTDiR\DiSM_MOUNT
SET WiMFiLE=%WR81%\sources\install.wim
MD "%MOUNT%"
"%DiSMW10%" /Mount-Image /ImageFile:"%WiMFiLE%" /Index:1 /MountDir:"%MOUNT%"

REM Enabled .Net Framework 3.5 Features Windows 8.1, please wait ...
SET SXSDiR=X:\sources\sxs
"%DiSMW10%" /image:"%MOUNT%" /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:"%SXSDiR%"

REM Intergrating Windows Updates Downloader ^(2015-03-25^)
REM * This will require some time, please be patient ...
SET WUDDiR=D:\Downloads\SOFTWARE\[WUD]\windows-8.1-update-x86
SET SCRATCH=%WORKDiR%\MOUNTDiR\SCRATCH
MD "%SCRATCH%"
REM * Add-Package Windows 8.1 Update 1 Update Packs,
SET LOGFiLE=%WR81%\logfiles\Integrating WUD Rollup 2015-03-25.log
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2919442-x86.msu" /ScratchDir:"%SCRATCH%" > "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2919355-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2932046-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2937592-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2938439-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2934018-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2959977-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2939087-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB2975061-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Update Packs\Windows8.1-KB3012199-x86.msu" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
REM * Add-Package Security Updates ...
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Security Updates" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
REM * Add-Package Non-Security Updates ...
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Non-Security Updates" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
REM * Add-Package Optional Updates ...
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\Optional Updates" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
REM * Add-Package .NET Framework 3.5 Updates ...
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\.NET Framework 3.5 Updates" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"
REM * Add-Package .NET Framework 4.5.2 Updates ...
SET LOGFiLE5F=%WR81%\logfiles\Update Packs.log
"%DiSMW10%" /Image:"%MOUNT%" /Add-Package /PackagePath:"%WUDDiR%\.NET Framework 4.5.2 Updates" /ScratchDir:"%SCRATCH%" >> "%LOGFiLE%"

The operation completed successfully.
Screenshot:


If you planned to reduced or slimmingdown with WinReducer 
"KEEP: "Optimizations - EXPERT - Net Framework Complete Cleanup"
otherwise Net Framework 3.5 will be broken after installing windows!

Sorry and hope this helps some Smile


Last edited by home7echers on Sat 2 May 2015 - 19:05; edited 3 times in total (Reason for editing : corrections)
SL2

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Tue 27 Jan 2015 - 6:50
brittech wrote:Hi

This is how it worked for me.
You missed source in line 2, and it should be mountdir in line 3:
Code:
dism   /mount-image   /imagefile:D:\Win81x64\sources\install.wim  /index:1   /mountdir:D:\wimoffline
dism   /image:D:\wimoffline   /enable-feature   /featurename:NetFx3   /All   /Source:D:\Win81x64\sources\sxs
dism   /commit-image   /mountdir:D:\wimoffline
avatar
brittech

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Tue 27 Jan 2015 - 22:06
Thanks SL2, you're absolutely right  Very Happy
I've added a comment to that post so folks look at yours for the correction.
Shubho
http://www.branham.org

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Sat 18 Apr 2015 - 14:18
this method doesn't worked for me...

I am having this message what to do?

avatar
KrX

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Sat 18 Apr 2015 - 14:45
hi,
im not really into it but i think brittech could help

maybe you should post the log "c:\windows\logs\dism\dism.log"

here
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Sat 18 Apr 2015 - 14:55
Hello,

I really encourage you to integrate net framework 3.5 before reducing your ISO (using WinReducer "System - Integrate Net framework 3.5" ... this will ensure that you won't have any troubles after slimming down !

But don't worry I know exactly why this happens, so I will add a fix once I will have enough time !

Have a good day !
avatar
brittech

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Sat 18 Apr 2015 - 18:46
Shubho wrote:this method doesn't worked for me...

I am having this message what to do?

Hi Shubho

The error was given because it couldn't find the SXS files it needs to enable NetFX3.
Did you copy the DVD sources\sxs folder to your computer??

For example, if my Windows 8.1 DVD is in E:\ drive of my computer, the Source would be ....

Code:
/Source:E:\sources\sxs

If you instead want to copy the DVD sources\sxs folder to your computer, that should be fine.
First copy the complete folder from the DVD to your C:\ drive, so that you have the C:\sxs folder
Then, the source would be ok, in your original command.

Code:
dism   /mount-image   /imagefile:C:\install.wim  /index:1   /mountdir:C:\wimoffline
dism   /image:C:\wimoffline   /enable-feature   /featurename:NetFx3   /All   /Source:C:\sxs
Shubho
http://www.branham.org

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Mon 27 Apr 2015 - 13:05
ok I will try it and please provide print option in your web interface for faster printing.
Shubho
http://www.branham.org

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Mon 27 Apr 2015 - 13:42
I have tried above method still it is showing the same message.so I have uploaded dism.log file->

https://userscloud.com/81lwf4df3id7 .
avatar
brittech

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Mon 27 Apr 2015 - 18:21
Shubho

Please answer these questions before we continue

- What DVD source did you use for the SXS folder?  Original DVD?  Original ISO?  or Modified ISO???
- How are you copying the SXS folder from the DVD to your C: drive?
- Has the install.wim file that you are mounting been changed in any way?  Updates integrated?  Slimmed??
avatar
winterstorm2050
Admin
https://www.winreducer.net/

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Wed 29 Apr 2015 - 10:02
Hello guys,

If you are trying to integrate Net Framework 3.5 after installing an ISO created by WinReducer ... unfortunately Net Framework 3.5 will be broken !

Don't worry I know exactly why, and I've planned to deployed a fix in the next weeks.

To by pass the problem, you could directly integrate Net Framework 3.5 using WinReducer (before installation) by using "System - Integrate Net Framework 3.5" : if you are using an official MS ISO, you have nothing to do except choosing the path with the button "..." and only use "OK" (= do not change the detected folder path). WinReducer will configure everything for you. Than use "APPLY" button to create your customized ISO with Net Framework 3.5 integrated.

Could you please also answer to brittech questions, these are really important to help you solve your problem.

Have a good day !
Shubho
http://www.branham.org

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Fri 1 May 2015 - 22:07
What DVD source did you use for the SXS folder?  Original DVD?  Original ISO?  or Modified ISO???

I really don't know....I got this windows 8.1 pro DVD from my friend. but one information I can give you it shows two option during the installation process
1>Windows 8.1 Pro
2>Windows 8.1 Pro Pre-activated

may be this could help you....I tried to modify 2nd option with winreducer.

How are you copying the SXS folder from the DVD to your C: drive?

I followed the exact steps that you mentioned in this article. but same result is coming.like the picture above I have uploaded.

Has the install.wim file that you are mounting been changed in any way?  Updates integrated?  Slimmed??

no I didn't modified it. but separately I used the batch file that you have uploaded.Thought that it would work.... all went well except the netfx3 integration didn't worked.
avatar
brittech

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Fri 1 May 2015 - 22:57
Shubho

The DVD you are using has probably been modified.  Maybe you could ask your friend to confirm that.
I think it has updates already integrated, and if it has already been modified then what you want to do may not be possible now.  You will need an original DVD or ISO.

There is one other option.  The link below is an application that attempts to enable DotNet 3.5 after installation.  It includes all the necessary files.  This has worked for me in the past, but I prefer to enable it at the source (from the beginning, as mentioned above).

LINK
Size:  63.7mb
MD5:  F82FCE1D865BF70CBBA99CFC3B41BD1D
Shubho
http://www.branham.org

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Sat 2 May 2015 - 10:02
Message reputation : 100% (1 vote)
Thank you for the suggestion....I will try it. later I will inform you what happened.
Shubho
http://www.branham.org

Re: [ANSWERED] Never able to get .Net Framework 3.5 to work... Please help

on Sat 4 Jul 2015 - 10:44
Message reputation : 100% (1 vote)
Thank you...for the software link.it did worked. I also tried downloading sxs folder manually and used the dism commands. Both worked....actually my windows 8.1 dvd sxs folder didn't contains all the files that's why it was showing errors.
View previous topicBack to topView next topic
Permissions in this forum:
You cannot reply to topics in this forum