Go down
Hanyo
Hanyo

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Tue 17 Sep 2019 - 21:55
I think, this bug is probably the same as descibed in [You must be registered and logged in to see this link.].
But because there are several bugs handled in this thread, I'd rather open a new one.

First my wccf: klick

Although update cleanup is not enabled, .Net3.5 cannot be enabled, neither through the Windows Features dialog, nor with DISM. In both cases I get the same error message: 



[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Error211
[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Error21

"The referenced assembly could not be found."

If I already integrate .Net3.5 into the ISO, it works fine with the same wccf.
neo
neo

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty Re: [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Wed 18 Sep 2019 - 4:42
hi Hanyo,
I wonder if it's breaking because you chose to remove these:
Features - Windows PowerShell
Remove - Modern UI Apps - Framework (Advertising SDK)
Remove - Modern UI Apps - Framework (Chat)
Remove - Modern UI Apps - Framework (Contact)
Remove - Modern UI Apps - Framework (Email)
Remove - Modern UI Apps - Framework (Microsoft Store Services)
Remove - Modern UI Apps - Framework (People)
Remove - Modern UI Apps - Framework (Phone Call History)
Remove - Modern UI Apps - Framework (Task)
Remove - Modern UI Apps - Framework (User Data Account)
Remove - Modern UI Apps - Framework (Windows Mixed Reality SDK)
Remove - Modern UI Apps - Framework (Xbox LIVE Games)

Especially the first two.

Kind regards,
Neo
Hanyo
Hanyo

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty Re: [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Wed 18 Sep 2019 - 17:38
Thanks, neo. My first thought was, that a dependency on the items you mentioned cannot explain why an ISO with integrated NetFx3 works with the same wccf.

But anyway, I made a test with all of your items deselected. Result: Still the same error "The referenced assembly could not be found."
KrX
KrX

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty Re: [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Wed 18 Sep 2019 - 17:54
hi,

for my german iso i need to keep those which you removed:

Code:
<Element Category="Services" Name="Update Orchestrator Service" Selected="true" Value="5" />
<Element Category="Services" Name="Windows Update Service" Selected="true" Value="5" />

at least it was on RS5 need to test it soon on RS6


EDIT: @neo

for my RS5 iso i can remove the components you mentioned only "Framework (.NET Native)" was needed
neo
neo

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty Re: [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Wed 18 Sep 2019 - 19:17
Hanyo wrote:Thanks, neo. My first thought was, that a dependency on the items you mentioned cannot explain why an ISO with integrated NetFx3 works with the same wccf.

But anyway, I made a test with all of your items deselected. Result: Still the same error "The referenced assembly could not be found."

Hanyo,
Are you familiar with DISM UI ? (tool used to add updates to the ISO)
DISM UI generates errors, if you rename the NetFX3 package, and then try to add it.
Not sure that's your case.

I'd recommend to try DISM UI, and if you still get errors , maybe the errors will explain the root cause.


Kind regards,
Neo
Hanyo
Hanyo

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty Re: [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Wed 18 Sep 2019 - 20:37
Hi neo,

I havn't renamed the package and again: When I integrate it in the ISO with winreducer then it works.

In the past, I integrated already updates with dism but because it also works with winreducer, now I always use that.

I tested with an ISO without integrated updates (and no integrated NetFx3 / build 17763.1) with the same wccf: Same negativ result. So it has nothing to do with update integration.

I think now it could have to do with WinSxS cleanup (intall.wim). I will test it.
Hanyo
Hanyo

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty Re: [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Thu 19 Sep 2019 - 11:48
Yep, when I deselect WinSxS folder cleanup (install wim) I can install NetFx3 with DISM. I can't do that with "Windows Features aktivate or deactivate" Dialog, but this for sure because I removed windows update (as KrX noticed).

In an Windows installation with nothing else but WinSxS cleanup the installation of NetFx3 fails.

Conclusion:

WinSxS folder cleanup (install wim) breaks Dotnet 3.5 installation.

I also found out that in the untouched (except WinSxS cleanup) installation it's not possible to activate the SMB1.0 support. Same error: "The referenced assembly could not be found." So maybe WinSxS cleanup breaks the possibility to install Features completely.
KrX
KrX

[SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable Empty Re: [SOLVED] [EX-100 2.2.2.0] [RS5 Build17763.737] Dotnet Framework 3.5 not installable

on Sun 13 Oct 2019 - 2:34
hi, im closing this thread since there are some other which discuss the same like this one:

[You must be registered and logged in to see this link.]
Back to top
Permissions in this forum:
You cannot reply to topics in this forum